Mac adresi üzerinden port bulmak

Backbone switch'e gir enable Şifreni gir
show ip arp 10.1.1.111    komutu ile mac adresini öğren
show mac address-table address 3c52.8233.6ff5       komutu ile bu mac adresi hangi potta ve o portta ne takılı bunu öğren (genelde kenar switch takılıdır) biz burada kenar switch bulduğumuzu var sayıyoruz
sh int status   komutu ile portlara takılı cihazları görüyoruz
bu porta kenar switch takılı kenar switch'e gidip aunı komutu çalıştırıyoruz
show mac address-table address ace2.d35b.96e4  bu komut ile bu mac adresi hangi porta takılı buluyoruz

Vlan değiştirmnek

Bulduğumuz porta bağlı cihazın vlanını değiştiriyoruz
conf ile configrations a git
int Gi1/0/11  komutu ile 11 inci potun ayarlarına git. sizde bu port değişik olacak aynısını yazmayın
switchport access vlan 100 "bu komut ile cihazı vlan 100 e atıyoruz bu işlemin ardından cihaz yeni vlana geçecek portu aç kapa yaparak yeni ip adresini almasını sağlıyalım.
shut ve ardından no shut
do sh int status ile portun son durumunu kontrol edin
description kullanıcılar "komutu ile porta açıklama yazın no desc ile açıklamayı silebilirsiniz
do wr mem ile yaptığınız değişiklikleri kaydetmeyi unutmayın yoksa switch kapanıp açıldığında tüm yaptığınız ayarlar kaybolur.
exit ile çık

Switch üzerinde poe açmak

configure terminal
interface fastethernet 4/1
power inline auto
end
show power inline fastethernet 4/1

Vlan oluşturma
en
conf
vlan 100
name Kullanicilar
do show vlan brief
do wr mem


kenar switch bir porta trunk vermek
en
conf
interface Fa0/1
switchport mode trunk
Ama bunun için portun karsiliginda bulunan kenar switch üzerinde de ayar yapmaliyiz.

Bir switch'e erişim için ip atamak

conf t
int vlan 1
ip add 192.168.1.28 255.255.255.0
ip default-gateway 192.168.1.1
do wri mem
end
show ip interface brief

SSH erişimi vermek:

conf t
username ferhat privilege 15 secret şifreni gir
enable secret şifreni gir    enable parolasını giriyoruz
service password-encryption    şifreyi cleartext olarak okunmasını engelliyoruz

Daha sonra router veya switch’in çalışacağı alan adını yazıp 2048 bit’lik anahtarımızı oluşturuyoruz.
ip domain-name ferhatyildiz.com.tr
crypto key generate rsa

Şimdi, SSH yönetimine izin verip telnet’i devre dışı bırakıyoruz.
line vty 04

SSH versiyonunun 2 olmasına dikkat edelim.
ip ssh version 2
do sh ip ssh

Cihazlarımıza erişim yapabilecek IP adreslerini bir access-list yazarak sınırlıyoruz ve bu kısıtlamaya bir de boşta kalma süresi koyarak güvenlik seviyesini biraz daha yukarı çekiyoruz.
ip access-list standard ACL-SSH
permit 192.168.95.0 0.0.0.255
line vty 0 4

AAA (kimlik doğrulama, yetkilendirme ve hesap yönetimi) hizmetlerini etkinleştirerek, cihaza her giriş yapmaya çalıştığımızda enable parolasının sorulmasını sağlayabiliriz.
aaa new-model

Portun err-disabled'e düşmesi hakkında switch koruma modudur aşağıdaki komut ile nelere karşı portların korunduğunu görebilirsiniz
show errdisable detect
show errdisable recovery
No Keepalive komutu ile portu düzelte biliyoruz.

SNMP iletişimini açmak
configure terminal
snmp-server community monitor ro
configure terminal
snmp-server community public
do wr mem

Bir portun sök tak işleminde up / down olduğunu anlamak için 
term mon
term no mon